同花顺缠论画线主图未加密选股指标公式源码


来源: 网络 时间: 2022-07-16 20:42:01 人气: 27 评论: 0

同花顺缠论画线主图未加密选股指标公式源码

源码正文:

KU1:=IF(HIGH=HHV(HIGH,3),1,0);
kd1:=IF(LOW=LLV(LOW,3),1,0);
UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0
AND KU1=0,REF(HIGH,2),REF(HIGH,2+BArslAst(REF(KU1,2)=1
AND REF(KU1,1)=0 AND KU1=0)));
DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(KD1,2)=1
AND REF(KD1,1)=0 AND KD1=0)));
HV:=H>UL AND H>REF(H,1) ;
LV:=L<DL AND L<REF(L,1) ;
GP:=BARSLAST(HV);
DP:=BARSLAST(LV);
IP:=IF(GP=0,DP,GP)>3;
HV1:=HV AND IP AND H>=HHV(H,BARSLAST(LV));
LV1:=LV AND IP AND L<=LLV(L,BARSLAST(HV));
DRAWLINE(LV1,LOW,HV1, HIGH,0),coloryellow,LINETHICK2;
DRAWLINE(HV1,HIGH,LV1, LOW,0),colormagenta,LINETHICK2;
///加入中枢判定
//简化版
N1:=10;N2:=10;DISP:=2;K:=1;
P1:=PEAK(1,K*N1,1);
P2:=PEAK(1,K*N1,2);
WP1:=PEAKBARS(1,K*N1,1);
WP2:=PEAKBARS(1,K*N1,2);
T1:=TROUGH(2,K*N2,1);
T2:=TROUGH(2,K*N2,2);
WT1:=TROUGHBARS(2,K*N2,1);
WT2:=TROUGHBARS(2,K*N2,2);
TJ1:=P1>T1 AND P2>T2 ;
ZD:=MAX(T1,T2);
ZG:=MIN(P1,P2);
LL:=MIN(T1,T2);
HH:=MAX(P1,P2);
TJ2:=FILTER(ZG>ZD,2);
TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
TJ4:=TJ1 AND TJ2 AND NOT(TJ3);
TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1)) AND ZD<REF(ZD,REF(BARSLAST(TJ4),1));
TJ8:=TJ4 AND NOT(TJ5 OR TJ6 OR TJ7);
ZSD:=IF(TJ8,ZD,REF(ZD,1));//,coloryellow;
ZSG:=IF(TJ8,ZG,REF(ZG,1));//,colormagenta;
ZSH:=IF(TJ8,HH,REF(HH,1));//,colorblue;
ZSL:=IF(TJ8,LL,REF(LL,1));//,colorgreen;
STICKLINE(TJ8,ZSH,ZSL,0,-1),colormagenta;
STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),colormagenta;
DRAWTEXT(DISP=2,ZSH,''),colorwhite;
//中枢高
中枢高:ZSG,colormagenta;
POLYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,colormagenta;
//中枢低:
中枢低:ZSD,coloryellow;
POLYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,coloryellow;
//中枢最高:
中枢最高:ZSH,colorred;
POLYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,colorred;
//中枢最低:
中枢最低:ZSL,colorgreen;
POLYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,colorgreen;
//趋势高:
//QSGD1:POLYLINE(DISP=3,zig(1,K*N1)),colorblue;
//趋势低:
//QSDD1:POLYLINE(DISP=3,ZIG(2,K*N2)),colorblue;
MA5:MA(CLOSE,5),COLORFF00FF,Linethick1;
//COLORFF00FF,LINETHICK2;
命真好:=MA5>REF(MA5,1);
命真坏:=MA5<REF(MA5,1);
//判定:
PARTLINE(MA5,命真好,coloryellow,命真坏,colorblue,MA5,COLORFF00FF),linethick3;
//F1:IF(MA5<REF(MA5,1),MA5,NULL),colorwhite,LINETHICK2;

同花顺黄金量柱子未加密选股指标公式源码

源码正文:

预测量万:=IF(ISNULL(REFX(&CLOSE,1)) AND stRFIND(PERIODnaME,"日线"),vol*240/FROMOPEN,0)/10000;//线形不输出
成交量万:VOL/10000,COLOR00ffff;//线形不输出 //文章来至程序化交易网 cxh99.com//
倍量:VOL>=REF(V,1)*1.8 AND C>REF(C,1),coloryellow;
低量:VOL<REF(LLV(VOL,13),1),colormagenta;
平量:Abs(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03,colorwhite;
TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.CXH99.COM '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'');
倍缩:VOL<=REF(V,1)*0.5,colorcyan;
梯量:COUNT(V>REF(V,1),3)=3 AND COUNT(C>O,3)=3,colorgray;
缩量涨:COUNT(C>REF(C,1),2)=2 AND COUNT(V<REF(V,1),2)=2,colorblue;
STICKLINE(ISNULL(REFX(&CLOSE,1)) AND STRFIND(PERIODNAME,"日线"),预测量万*10000,0,11,1),COLORffffff;
DRAWTEXT(倍量,V*1.11,'倍'),coloryellow;
STICKLINE(C>=O,0,V,9,0),color0000aa;
STICKLINE(C<O,0,V,9,0),color00aa00;
STICKLINE(倍量,0,V,5,0),coloryellow;
STICKLINE(低量,0,V,5,0),colormagenta;
STICKLINE(平量,0,V,5,0),colorwhite;
STICKLINE(倍缩,0,V,5,0),colorcyan;
STICKLINE(梯量,0,V,5,0),colorgray;
STICKLINE(缩量涨,0,V,5,0),colorblue;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK,colorred,LINETHICK1;
STICKLINE(黄金柱,0,V,0.5,0),colorred;
DRAWTEXT(黄金柱,V*1.24,'黄'),colorred;
DRAWTEXT(VOL=HHV(VOL,0),HHV(VOL,30)*0.938,'天量'),colorred;
MA5:MA(V,5),colorred;
MA35:MA(V,35),colormagenta;
MA120:MA(V,120),coloryellow,LINETHICK2;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:=VOL,POINTDOT;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),colorred,POINTDOT,NODRAW;
主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(主动买盘>0,0,主动买盘,2,0),colorred,NODRAW;
STICKLINE(主动卖盘<0,0,主动卖盘,2.4,0),colorgreen;
DRAWTEXT(VOL=HHV(VOL,0),HHV(VOL,30)*0.918,'天量'),colorred;

评论