通达信暴妖突破未加密选股指标公式源码


来源: 网络 时间: 2022-07-16 21:52:30 人气: 68 评论: 0

通达信暴妖突破未加密选股指标公式源码

源码正文:

ma10:=MA(CLOSE,10){XG51};
MA54:=MA(CLOSE,54){XG51};
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5{XG51};
HJ_9:=FILTER(HJ_8,10){XG51};
HJ_10:=BArslAst(HJ_9){XG51};
HJ_11:=REF(HIGH,HJ_10+2){XG51};
HJ_12:=REF(HIGH,HJ_10+1){XG51};
HJ_13:=REF(HIGH,HJ_10){XG51};
HJ_14:=MAX(HJ_11,HJ_12){XG51};
HJ_15:=MAX(HJ_14,HJ_13){XG51};
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5{XG51};
HJ_17:=HJ_10<150{XG51};
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30{XG51};
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50{XG51};
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30{XG51};
HJ_21:=vol/MA(VOL,5)<3.5{XG51};
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80{XG51};
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22{XG51};
暴利:=FILTER(HJ_25,15){XG51};
PL1:=(((CLOSE-MA54)/MA54)<0.1){XG51};
PL2:=(((CLOSE-MA10)/MA10)<0.3){XG51};
偏离率:=(((PL1=1) AND (PL2=1))*0.2){XG51};
平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1){XG51};
妖股突破:=平台突破=-0.1{XG51};
XDF:=(暴利 OR 妖股突破){XG51};
VARA:=dma(AMOUNT/VOL/100,VOL/CAPITAL){XG51};
VARAA:=DYnaINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05){XG51};
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2){XG51};
XG:XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA{X_G^5.1_C_N_{};

通达信妖股如何启动主图未加密选股指标公式源码

源码正文:

ZF:((H-REF(C,1))/(REF(C,1))+(REF(C,1)-L)/(REF(C,1)))*100,COLORmaGENTA,NODRAW{XG51};
CF:(C-REF(C,1))/(REF(C,1))*100,COLORBLUE,NODRAW{XG51};
DCF:("999999$C"-REF("999999$C",1))/(REF("999999$C",1))*100,COLORLICYAN,NODRAW{XG51};
DRAWICON(CURRBARSCOUNT<1000 AND PERIOD=5 AND((DCF<0.2 AND CF>9.75)),H*1.05,29){XG51};
DRAWKLINE(H,O,L,C){XG51};
stICKLINE(PERIOD=5 AND CF>1.0975 AND H=C AND O<>C,O,O+(H-O)/3,2.5,0),COLORLIMAGENTA{XG51};
STICKLINE(PERIOD=5 AND CF>1.0975 AND H=C AND O<>C,O+(H-O)/3,O+(H-O)/3*2,2.5,0)COLORBLUE{XG51};
STICKLINE(PERIOD=5 AND CF>1.0975 AND H=C AND O<>C,O+(H-O)/3*2,C,2.5,0),COLORLIMAGENTA{XG51};
M60:MA(C,60)COLORCYAN{XG51};
M20:MA(C,20)COLORLIMAGENTA{XG51};
M10:MA(C,10)COLORBLUE{XG51};
M5:MA(C,5)COLORRED{X*G~5-1*C*N*{};

通达信 指标 公式

评论