通达信MACD金叉费数标注未加密选股指标公式源码


来源: 网络 时间: 2022-07-16 21:52:30 人气: 36 评论: 0

通达信macd金叉费数标注未加密选股指标公式源码

源码正文:

dif:ema(CLOSE,12)-Ema(CLOSE,26){XG51};
DEA:EMA(DIF,9){XG51};
macd:(DIF-DEA)*2,COLORstICK{XG51};
STICKLINE(MacD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORGRAY{XG51};
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORLICYAN{XG51};
DIF升:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORWHITE,LINETHICK1{XG51};
JCCOUNT1:=COUNT(crOSS(DIF,DEA),BArslAST(DEA>=0)){XG51};
零下金叉:CROSS(DIF,DEA) AND DIF<0.0 AND COUNT(JCCOUNT1=1,21)=1,NODRAW,COLORCYAN{XG51};
STICKLINE(零下金叉,0,DEA,0.0,0),COLORCYAN{XG51};
DRAWTEXT(零下金叉,DEA/2,' 零下一'),COLORCYAN{XG51};
零下二次:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=2,21)=1,NODRAW,COLORCYAN{XG51};
STICKLINE(零下二次,0,DEA,0.0,0),,COLORCYAN{XG51};
DRAWTEXT(零下二次,DEA/2,' 零下二'),COLORCYAN{XG51};
零下三次:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=3,21)=1,NODRAW,COLORCYAN{XG51};
STICKLINE(零下三次,0,DEA,0.0,0),COLORCYAN{XG51};
DRAWTEXT(零下三次,DEA/2,' 零下三'),COLORCYAN{XG51};
零下四次:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=4,21)=1,NODRAW,COLORCYAN{XG51};
STICKLINE(零下四次,0,DEA,0.0,0),,COLORCYAN{XG51};
DRAWTEXT(零下四次,DEA/2,' 零下四'),COLORCYAN{XG51};
零下五次:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=5,21)=1,NODRAW,COLORCYAN{XG51};
STICKLINE(零下五次,0,DEA,0.0,0),COLORCYAN{XG51};
DRAWTEXT(零下五次,DEA/2,' 零下五'),COLORCYAN{XG51};
JCCOUNT2:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA<=0)){XG51};
零上金叉:CROSS(DIF,DEA) AND DIF>0.0 AND COUNT(JCCOUNT2=1,21)=1,NODRAW,COLORLIMAGENTA{XG51};
STICKLINE(零上金叉,0,DEA,0.0,0),COLORLIMAGENTA{XG51};
DRAWTEXT(零上金叉,DEA/2,'零上一 '),COLORLIMAGENTA{XG51};
零上二次:CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=2,21)=1,NODRAW,,COLORLIMAGENTA{XG51};
STICKLINE(零上二次,0,DEA,0.0,0),COLORLIMAGENTA{XG51};
DRAWTEXT(零上二次,DEA/2,' 零上二'),COLORLIMAGENTA{XG51};
零上三次:CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=3,21)=1,NODRAW,COLORLIMAGENTA{XG51};
STICKLINE(零上三次,0,DEA,0.0,0),COLORLIMAGENTA{XG51};
DRAWTEXT(零上三次,DEA/2,' 零上三'),COLORLIMAGENTA{XG51};
零上四次:=CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=4,21)=1,NODRAW,COLORLIMAGENTA{XG51};
STICKLINE(零上四次,0,DEA,0.0,0),COLORLIMAGENTA{XG51};
DRAWTEXT(零上四次,DEA/2,' 零上四'),COLORLIMAGENTA{XG51};
零上五次:=CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=5,21)=1,NODRAW,COLORLIMAGENTA{XG51};
STICKLINE(零上五次,0,DEA,0.0,0),COLORLIMAGENTA{XG51};
DRAWTEXT(零上五次,DEA/2,' 零上五'),COLORLIMAGENTA{XG51};
A1:=BARSLAST(REF(CROSS(DIF,DEA),1)){XG51};
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA) AND DEA<0{XG51};
STICKLINE(底背离,0,0.03,3,0),COLOR00FF00{XG51};
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORWHITE,LINETHICK4{XG51};
DRAWTEXT(底背离,DEA,' 底背离'),COLORFF00FF{XG51};
A2:=BARSLAST(REF(CROSS(DEA,DIF),1)){XG51};
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF){XG51};
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORCYAN,LINETHICK2{XG51};
DRAWTEXT(顶背离,DEA,' 顶背离'),COLORCYAN{XG51};
DRAWTEXT(零下金叉 AND 零下二次 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2{XG51};
JC:=CROSS(DIF,DEA),NODRAW{XG51};
TJ:=SUMBARS(JC,1),NODRAW{XG51};
SC:=CROSS(DEA,DIF),NODRAW{XG51};
TS:=SUMBARS(SC,1),NODRAW{XG51};
F:=0.1{XG51};
DRAWTEXT(JC,-F,'1'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=3 AND MACD>0,-F,'3'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=5 AND MACD>0,-F,'5'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=8 AND MACD>0,-F,'8'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=13 AND MACD>0,-F,'13'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=21 AND MACD>0,-F,'21'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=34 AND MACD>0,-F,'34'),COLORLIMAGENTA{XG51};
DRAWTEXT(TJ=55 AND MACD>0,-F,'55'),COLORLIMAGENTA{XG51};
DRAWTEXT(SC,F,'1'),COLORCYAN{XG51};
DRAWTEXT(TS=3 AND MACD<0,F,'3'),COLORCYAN{XG51};
DRAWTEXT(TS=5 AND MACD<0,F,'5'),COLORCYAN{XG51};
DRAWTEXT(TS=8 AND MACD<0,F,'8'),COLORCYAN{XG51};
DRAWTEXT(TS=13 AND MACD<0,F,'13'),COLORCYAN{XG51};
DRAWTEXT(TS=21 AND MACD<0,F,'21'),COLORCYAN{XG51};
DRAWTEXT(TS=34 AND MACD<0,F,'34'),COLORCYAN{XG51};
DRAWTEXT(TS=55 AND MACD<0,F,'55'),COLORCYAN{X_G^5_1_C_N_{};

通达信火鸟涨停未加密选股指标公式源码

源码正文:

ma5:=MA(C,5){XG51};
布林上轨:=MA(CLOSE,24)+2*stD(CLOSE,24){XG51};
XG1:=O<MA5 AND C>MA5 AND O<布林上轨 AND C>布林上轨 AND MA(C,60)>REF(MA(C,60),1) AND C/REF(C,1)>1.03{XG51};
XG:COUNT(REF(XG1,1),5)<1 AND XG1{X_G*5-1_C_N_{};

公式 通达信 指标

评论