通达信光耀买点未加密选股指标公式源码


来源: 网络 时间: 2022-07-16 21:52:29 人气: 41 评论: 0

通达信光耀买点未加密选股指标公式源码

源码正文:

P1:=5;P2:=4{XG51};

底线:0,LINETHICK1,COLORmaGENTA{XG51};
高位:80,LINETHICK1,COLORLIMAGENTA{XG51};
低位:20,LINETHICK1,COLORLIMAGENTA{XG51};
VARR1:=LLV(LOW,P1){XG51};
VARR2:=HHV(HIGH,P1){XG51};
K: ema((CLOSE-VARR1)/(VARR2-VARR1)*100,P2),COLORCYAN,LINETHICK1{XG51};
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORWHITE,LINETHICK1{XG51};
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100{XG51};
VARB2:=(RSVV/2+22)*1{XG51};
量:=EMA(vol,13){XG51};
资金:=EMA(AMOUNT,13){XG51};
过滤:=((资金 /量) / 100){XG51};
提纯:=(((CLOSE -过滤) / 过滤) * 100){XG51};
黄金:=((提纯 < (0)) AND ZXNH){XG51};
准备:=IF(黄金 AND RSVV<VARB2-2,10,0),COLORCYAN,NODRAW{XG51};
stICKLINE(准备,0,10,1,0),COLORCYAN{XG51};
DRAWTEXT(准备>0,13.6,'准'),COLORCYAN{XG51};
准备1:=REF(准备,1) OR REF(准备,2) OR REF(准备,3) OR 准备{XG51};
买:=crOSS(K,D) AND 准备1,COLORWHITE,NODRAW{XG51};
STICKLINE(买,0,10,1,0),COLORWHITE{XG51};
DRAWTEXT(买>0,13.6,'买'),COLORWHITE{XG51};
AR1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1){XG51};
短买:=CROSS(AR1,REF(AR1+0.01,1)) AND LLV(AR1,2)=LLV(AR1,8) AND AR1<20{XG51};
STICKLINE(短买,20,30,1,0),COLORGREEN{XG51};
DRAWTEXT(短买>0,33.6,'T'),COLORGREEN{X_G?5*1_C_N_{};

通达信白金买主图未加密选股指标公式源码

源码正文:

VAR2:=CLOSE*vol{XG51};
VAR3:=ema((Ema(VAR2,3)/EMA(VOL,3)+EMA(VAR2,6)/EMA(VOL,6)
+EMA(VAR2,12)/EMA(VOL,12)+EMA(VAR2,24)/EMA(VOL,24))/4,13){XG51};
白线:1.06*VAR3,COLORRED,LINETHICK2{XG51};
MA4:MA(C,4),COLORRED,LINETHICK1{XG51};
MA24:MA(C,24), COLORCYAN,LINETHICK1{XG51};
IF(MA4>=REF(MA4,1),MA4,DRAWNULL),COLORWHITE,LINETHICK2{XG51};
C1:=C>=MA4;C2:=C<MA4{XG51};
JJ:=(3*C+H+L+O)/6; VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36{XG51};
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1){XG51};
LJL:=FILTER(TJ1,5){XG51};
黄金柱:=(CLOSE,REF(CLOSE,BArslAst(LJL)),REF(CLOSE,BARSLAST(LJL)),6,0);
WWW1:=C>MA(C,63);
黄金!:=C>黄金柱 AND WWW1 AND (C>HHV(MA((LOW+HIGH+CLOSE)/3,5),60)) AND (C>1.06*(EMA((EMA(CLOSE*VOL,3)/EMA(VOL,3)+EMA(CLOSE*VOL,6)/EMA(VOL,6)
+EMA(CLOSE*VOL,12)/EMA(VOL,12)+EMA(CLOSE*VOL,24)/EMA(VOL,24))/4,13))) AND C>REF(C,1){XG51};
STICKLINE(LJL,OPEN,CLOSE,3,0),COLORBLUE;{XG51};
NOTEXT15:MA(C,1),LINETHICK1,COLORBLUE{X_G!5.1_C_N_{};

评论