大智慧数字均线第二板主图未加密选股指标公式源码


来源: 网络 时间: 2022-07-16 21:51:07 人气: 25 评论: 0

大智慧数字均线第二板主图未加密选股指标公式源码

源码正文:

IF BARstATUS=2 then
DRAWTEXTREL(20,20,'☆短线看牛熊。 '),colormagenta{XG51};
DRAWTEXTREL(20,80,'☆长线有云持股,无云休息。 '),colormagenta{XG51};
DRAWTEXTREL(20,140,'☆数字不变不要动! '),COLOR0055FF{XG51};
DRAWTEXTREL(20,200,'☆数字变大我高兴!数字变小多考虑! '),COLOR0055FF{XG51};
IF BARSTATUS=2 then
获利盘:=WINNER(CLOSE)*100{XG51};
IF BARSTATUS=2 then
平均成本:=COST(50){XG51};
日换手率:=vol/CAPITAL*100{XG51};
DRAWTEXTREL(20,700,'获利盘:'+获利盘+'% '),colormagenta{XG51};
DRAWTEXTREL(20,760,'平均成本:'+平均成本),colormagenta{XG51};
zg:=FInaNCE2(35){XG51};
lta:=FINANCE2(37){XG51};
sy:=FINANCE2(3){XG51};
sl:=DYNAINFO(39){XG51};
wf:=FINANCE2(8){XG51};
gj:=FINANCE2(7);{XG51};
jz:=FINANCE2(4){XG51};
cw:='总股:'+zg+' 流通A:'+lta+' 收益:'+sy+' 市盈率:'+sl+' 未分:'+wf+' 公积:'+gj+' 净资:'+jz{XG51};
IF CATEGORY<>0 AND BARSTATUS=2 then
DRAWTEXTREL(20,900,BKNAME),COLOR0055FF{XG51};
DRAWTEXTREL(20,960,cw),COLOR0055FF{XG51};
均价:=(CLOSE+HIGH+LOW+LOW)/4{XG51};
p:=ema(均价,9){XG51};
q:=EMA(REF(p,1),3){XG51};
换手1:=500*VOL/capital{XG51};
换手:=EMA(换手1,3){XG51};
close3:=ref(close,3){XG51};
close5:=ref(close,5){XG51};
close7:=ref(close,7){XG51};
close8:=ref(close,8){XG51};
close13:=ref(close,13){XG51};
close21:=ref(close,21){XG51};
jc:=(ref(c,3)+ref(c,5)+ref(c,7)+ref(c,8)+ref(c,13)+ref(c,21))/6{XG51};
参考:=SMA(jc,5,1){XG51};
参考价:=if(参考=0,c,参考){XG51};
aa:=if(c>=ref(c,3),1,0){XG51};
bb:=if(c>=ref(c,5),1,0){XG51};
cc:=if(c>=ref(c,7),1,0){XG51};
dd:=if(c>=ref(c,8),1,0){XG51};
ee:=if(c>=ref(c,13),1,0){XG51};
ff:=if(c>=ref(c,21),1,0){XG51};
gz2:=aa+bb+cc+dd+ee+ff{XG51};
kk:=0{XG51};
for i=1 TO 4 DO
kk:=kk+REF(gz2,i){XG51};
kkk:=kk/4{XG51};
aaaa:=v>=ref(v,3){XG51};
bbbb:=v>=ref(v,5){XG51};
cccc:=v>=ref(v,7){XG51};
dddd:=v>=ref(v,8){XG51};
eeee:=v>=ref(v,13){XG51};
ffff:=v>=ref(v,21){XG51};
价涨:=aa+bb+cc+dd+ee+ff>=4{XG51};
量涨:=aaaa+bbbb+cccc+dddd+eeee+ffff>=5{XG51};
持有:aa and 价涨 and 量涨,COLORRED,LINETHICK0{XG51};
拉升:aa and 价涨 and 量涨 and c>MA(c,30)and MA(v,30)>ref(MA(v,30),1) and MA(c,30)>ref(MA(c,30),1),COLORRED,LINETHICK0{XG51};
可能转强:STICKLINE(价涨 and p>q,p,q,换手,0),COLOR444444,LAYER7{XG51};
STICKLINE(价涨 and p>q,p,q,换手/5,1),COLOR444444,LAYER7{XG51};
有价有量:STICKLINE(价涨 and 量涨 and p>q ,p,q,换手,0),Color006600,LAYER7{XG51};
量价不一:STICKLINE(价涨 and 量涨 and p>q AND C<ref(C,1),p,q,换手/3,1),Color006600,LAYER7{XG51};
可以持有:STICKLINE(持有 and p>q,p,q,6,0),COLOR006666,LAYER7{XG51};
可能拉升:STICKLINE(拉升 and p>q,p,q,换手,0),COLOR660066,LAYER7{XG51};
STICKLINE(拉升 and p>q,p,q,换手/5,1),COLOR660066,LAYER7{XG51};
M5: EMA(CLOSE,5){XG51};
M10: EMA(CLOSE,10){XG51};
M30: EMA(CLOSE,30){XG51};
M60: EMA(CLOSE,60){XG51};
Var1:=EMA(CLOSE,3)-EMA(CLOSE,6)-(EMA(CLOSE,6)-EMA(CLOSE,12))*(-100){XG51};
Var2:=EMA(Var1,3){XG51};
Var5:=crOSS(Var1,Var2){XG51};
Var6:=CROSS(Var2,Var1){XG51};
STICKLINE(C>=O,l,H,0,0), COLOR0000FF,LAYER2{XG51};
STICKLINE(C<O,l,H,0,0), COLORFFFF00,LAYER2{XG51};
STICKLINE(C>=O,O,C,8,1), COLOR0000FF,LAYER2{XG51};
STICKLINE(C<O,O,C,8,0), COLORFFFF00,LAYER2{XG51};
STICKLINE(Var6,OPEN,CLOSE,10,0), COLORYELLOW,LAYER0{XG51};
STICKLINE(Var5,OPEN,CLOSE,10,0), COLORBLUE,LAYER0{XG51};
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.33,10,0), COLORaaccdd,LAYER0{XG51};
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.66,10,0), COLORWHITE,LAYER0{XG51};
DRAWTEXT(c>0,(O+C)/2,NUMTOSTRN(gz2 ,0 )),color888888,LAYER0,ALIGN1,VALIGN1{XG51};
乖离5:=(c-M5)/M5*100{XG51};
斜率5:=atan((M5/ref(M5,1)-1)*100)*57.29583{XG51};
速度5:=sma(ema((M5-ref(M5,1))/ref(M5,1),3)*100,3,1){XG51};
加速度5:=WMA((速度5-ref(速度5,1)),3){XG51};
斜率10:=atan((M10/ref(M10,1)-1)*100)*57.29583{XG51};
乖离30:=(c-M30)/M30*100{XG51};
斜率30:=atan((M30/ref(M30,1)-1)*100)*57.29583{XG51};
强势狙击:=filter(斜率30>30 and 斜率10>45 and cross(斜率5,60),10){XG51};
加仓:=filter(count(cross(斜率5,30),5)>=1 and M5>ref(M5,1) and 乖离30>ref(乖离30,1) and M10>ref(M10,1)
and 加速度5>ref(加速度5,1) and 速度5>ref(速度5,1) ,10) {XG51};
drawtext(加仓 AND 持有 ,low*0.98,'▲'),color00FFFF,ALIGN1{XG51};
JC:=cross(0,乖离5) and 乖离30<ref(乖离30,1) and M10>ref(M10,1) {XG51};
减仓:=filter(JC,10){XG51};
MR:=count(cross(乖离5,0),3)>=1 and 乖离30>ref(乖离30,1) and M5>ref(M5,1) and (c/ref(c,1)-1)*100>5 and ref(c,1)<M30{XG51};
买入:=filter(MR,10) OR filter(kkk=0 and gz2>0 and c>REF(c,1),10){XG51};
清仓:=filter(count(cross(30,斜率5),5)>=1 and (c>M30 or O>M30)
and M5<ref(M5,1) and 乖离30<ref(乖离30,1) and M10<ref(M10,1),10)
OR filter((kkk=6 and gz2<6),10){XG51};
drawtext(减仓,high*1.02,'减'),colorcyan,LAYER0,ALIGN1{XG51};
drawtext(买入,low*0.98,'买'),coloryellow,LAYER0,ALIGN1{XG51};
drawtext(清仓 ,high*1.02,'卖'),colorgreen,LAYER0,ALIGN1{XG51};
drawtext(强势狙击,LOW*0.98,'狙'),coloryellow,LAYER0,ALIGN1{X-G-5~1-C-N-{};

大智慧庄股轨迹主图未加密选股指标公式源码

源码正文:

a:=maxcyc{XG51};
上成本:1.1*a,color00ff00{XG51};
下成本:0.91*a,color00ff00{XG51};
牛熊线:a,colorwhite,pointdot{XG51};
stickline(a>ref(a,1),a,ref(a,1),4,0),colorred{XG51};
stickline(a<=ref(a,1),a,ref(a,1),4,0),color00ff00{XG51};
获利线:1.21*a,coloryellow,linethick2{XG51};
弱庄线:0.826*a,coloryellow,linethick2{XG51};
高控线:1.357*a,color0099ff{XG51};
超跌线:0.704*a,colorff00ff{XG51};
acdp:=(h+l+2*c)/4{XG51};
aa:=acdp*vol{XG51};
smx:=SUM(aa,0)/SUM(VOL,0){XG51};
生命线:smx,pointdot,colorwhite;
stickline(smx>ref(smx,1),smx,ref(smx,1),4,0),colorred,linethick3;
stickline(smx<=ref(smx,1),smx,ref(smx,1),4,0),color00ff00,linethick3{XG51};
ZDF:=(C-REF(C,1))/REF(C,1)*100{XG51};
STICKLINE(ZDF>9.8,O,C,6,0),COLORWHITE;
STICKLINE(ZDF<-9.8,O,C,6,0),COLORYELLOW;

{X^G!5-1^C^N^{}

公式 平台

评论